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1 Graph Utility 

Graph utility is a module of MiP-PSCT to view the results of MiP-PSCT applications in linear, 
semilog and logs scale. The input to this module is the binary file/s generated from MiP-PSCT 
applications. The selected graph from the binary file can be stored as graph files “grp”. Here window 
is split into two panes. In the first pane, the graph is plotted and the second pane contains a list 
having all the variables extracted from the binary file. X and Y-axis variables has to be selected from 
the list to plot the graph.  

A sample of MiGraph application is shown below. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

                                                          Figure 5.1: Sample Graph 

Features 

1. MiGraph enables the user to view Graph Data on a sheet; where in the titles of the graphs 
can be changed.  

2. The graph ranges can be changed.  

3. Multiple X and Y columns can be selected. If C1, C2, C3 and C4 are the sets of points 
available, then C1 vs. C2 and C3 vs. C4 can be plotted on the same graph.  

4. All the curves plotted can be viewed in a splitter window, which helps the user to keep track 
of the curves plotted.  

5. When the user selects the curves to be plotted, the dependent axis curve names appear in 
the colour of the plot. 

6. Two level Zoom is provided.  

7. The curves can be traced.  

8. The x-y co-ordinates can be read by placing the cursor on the graph 

9. The following entities can be formatted -  

10. Curves - the colour, thickness, symbols to appear on curves, the number of symbols to 
appear on a curve, title and font. 

11. Background colour. 
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12. Axis - Alignment (top, bottom, middle), colour, thickness, orientation of axis labels, precision 
of axis labels, number of ticks, colour of ticks. 

13. Grid Lines - colour and number of lines.  

14. User defined text can be added in the form of text boxes. These can be moved anywhere on 
the screen, formatted and deleted. The curve title can also be moved and formatted like any 
other text. 

15. The graph area can be defined in physical sizes. This helps the user to restrict the graph to 
a particular paper size (ex. 8.5” by 11.5”). The plot margins plot area and border margins 
can be formatted. Module supports printing. 

16. The graph can be printed on the top/bottom/middle/complete portion of the paper. 

17. The graphs can be saved and retrieved from user defined files. 

18. The curves can be viewed as points or continuous 

19. Similar graphs can be plotted at single click 

 

1.1 File 

The File menu offers the following commands: 

1.1.1 Creating a New Document 

Use “File > New” to create a new document in Graph Utility.  Select the type of new file you want to 

create in the File New dialog box. If the file extension is not provided, a default extension of  “grp” is 
assumed. 

Shortcuts  

Keys: CTRL+N   Toolbar:  

1.1.2 Import 

 

Use “File Import” or button on the toolbar located in the left-bottom corner of the Graph utility 

Window.  On selecting this option, a dialog will be popped up as shown.  On this dialog, click on the 
Browse button to select the file with extensions either  “bin” or “txt”. After selecting the file, click 
Open button on the File open dialog.  This command will make you to import files in txt or bin 
format.  Txt/Bin files should be obtained from MiP-PSCT application programs or should be created 

in the same format. 

 

 

 

 

 

 

The input text file format for the Graph utility is as below: 

 

Line 1 Title of the Graph 

Line 2 No. of Columns 

If no. of. columns are equal to 5. Line 3 to 7 is column variable names say C1,….,C5. Next five lines 
i.e., lines 8 to 12 are units corresponding to the column variables edited above. After editing this 
text, edit the 5 columns in the following fashion 

 

C1 C2 C3 C4 C5 
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1.1.3 File Open Command 

Use “File > Open” menu option to open an existing grp document in a new window.  More than one 

document can be opened at a time.  Use the Window menu to switch among the multiple open 
documents. 

Shortcuts 

Keys: CTRL+O   Toolbar:  

 

1.1.4 Close document 

Use “File > Close” to close all windows currently opened in the active document.  Make sure to 

save, if you close a document without saving, you lose all changes made since the last time you 
saved it.  Before closing an untitled document, Graph utility displays the Save as dialog box and 
suggests that you name and save the document. 

You can also close a document by using the Close icon on the document's window. 

 

1.1.5 Save document 

Use “File > Save” to save the active document to its current name and directory.  When you save a 

document for the first time, Graph utility displays the Save As dialog box to name your document.  If 
you want to change the name and directory of an existing documents before you save it, choose the 
Save As command. 

Shortcuts 

Keys: CTRL+S Toolbar:  

1.1.6 Save as document 

Use “File > Save as” to save and name the active document.  Graph utility displays the Save As 

dialog box to name your document. To save a document with its existing name and directory, use 
the Save command. 

 

1.1.7 Save as Image 

Use “File > Save as Image” to save the plotted graph.  Graph utility displays the Save Graph as an 

Image dialog box to name your document. To save an image with jpg format give name and 
directory, use the Save button. 

 

1.1.8 Print 

Use “File > Print” to print a document.   This command presents a Print dialog box, where you may 

specify the range of pages to be printed, the number of copies, the destination printer, and other 
printer setup options. 

Shortcuts 

Keys: CTRL+P   Toolbar: 

 

1.1.9 Print Preview 

Use “File > Print Preview” to display the active document, as it would appear when printed.  When 

you choose this command, the main window will be replaced with a print preview window in which 
one or two pages will be displayed in their printed format.  The print preview toolbar offers you with 
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options to view either one or two pages at a time; move back and forth through the document; zoom 
in and out of pages; and initiate a print job. 

 

1.1.10 Print Set up 

Use “File > Print set up” to select a printer and a printer connection.  This command presents a 

Print Setup dialog box, where you specify the printer and its connection. 

 

1.1.11 Page Setup 

Use “File > Page Set up” to set the page margin and graph position in the print.  On selecting this 

option the dialog box shown will be popped-up.  On this dialog box, graph position while printing can 
be fixed by clicking either Top or Middle or Bottom or Full. On selecting one of the four options 
previews of the graph placement while printing can be viewed. To change the border area and 
margins, type the values in the respective edit boxes.   

 

1.1.12 Exit 

Use “File > Exit” to end your Graph utility session.  You can also use the Close command on the 

application Control menu.  Graph utility prompts you to save documents with unsaved changes. 

Shortcuts Mouse: Double-click the application's Control menu button. 

Keys: ALT+F4 

 

1.2 Edit 

The Edit menu offers the following commands: 

 

1.2.1 Copy 

Select “Edit-> Copy” to copy the contents of the text box to clip board. In key board use Ctrl+C 
option  

 

1.2.2 Paste 

Select “Edit-> Paste” to paste the copied contents to the text box. In key board use Ctrl+V option to 
paste in the text box. 
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1.2.3 Delete Text Box 

Use “Edit > Delete Text Box” to delete a text box, select the text box and then use the option. 

 

1.2.4 Merge (Merges two binary files) 

Select “Edit >Merge”, to merge two *.bin file into one bin file. 

Requirements: 

1. The simulation time of two input bin files should be same. 

2. The time step of both the input bin files should be same. 

 

The merging of two bin file is useful in plotting graphs of different case studies together in one 
graph. 

On selecting this menu option, a dialog box will be popped up as shown. 

On this dialog click on the buttons to select bin files. After browsing the three bin files, click OK 
button. The two input bin files will be combined and written in the third bin file. This combined bin file 
can be imported to plot the graphs. 

 

1.2.5 Overcurrent Relay 

PowerRCD the relay co-ordination module of MiP-PSCT generates MiGraph compatible binary files. 
When MiGraph is invoked through the Database Manager the phase relay co-ordination curve 
binary file is automatically imported and corresponding columns are displayed in the second pane. 
The relay co-ordination graphs are plotted by selecting the required columns. (Note: for each relay 
select new independent group from the second pane). The plotted curve X and Y column numbers 
are displayed in the list box. MiGraph provides curve changes by 

Change Setting  

Change Base 

Complete relay curves can be plotted on Graph 

1.2.5.1 Change Setting 

Steps to move the co-ordination curve 

Graph utility provides a unique feature by which the co-ordination curves can be moved horizontally 
(by changing the plug setting) or vertically (by changing the time dial setting) from the second pane 
list box where the X and Y column numbers are displayed. To move the curve, double click on the 
Independent groups as shown in the diagram below. 
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Modify relay settings: From main menu select Edit > Overcurrent relay->Change settings which 

opens the Relay setting window. Select relay and click on > New settings button to change TDS and 
Plug setting. CT ratio will be displayed. 

Save Settings: Saves the new settings to the database.  

OK: With the updated settings relay curve appear on the graph and dialog closes. 

Cancel: Without change in relay settings dialog closes. 

This option can be selected by clicking right mouse button on the relay curve select Over current 
Relay > Change Setting 

1.2.5.2 Changing the base kV for curves 

The relay co-ordination curves are generated on a common kV base. MiGraph provides an option to 
view the curves on a different voltage. 
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Use “Edit > Overcurrent Relay >> change base” to change relay base kV for curves.  Open the 

Relay Data. File dialog appears, give the file name and click OK.  The following dialog appears. It 
displays the existing base, give new kV base.  All the curves are now plotted on new kV base. Even 
the curves, which are not plotted, are converted to new kV base. The main bin or text file is not 
modified 

 

This option can be selected by clicking right mouse button on the relay curve select Over current 
Relay > Change Base 

 

 

 

 

 

1.2.6 Write 

The plots displayed can be written to a text or dxf file using this option 

1.2.6.1 To Text file 

Use “Edit > Write >> To Text file” to convert the binary file (.bin) to text file(.txt) format.   

Conversion procedure: Select X-axis and Y-axis variables using x-axis and y-axis buttons.  After 
selecting the variables, choose this menu option.  On choosing this menu option, a dialog box 
prompting for the file name appears. Select the file name and file path where it has to be stored.  
This text file can be opened through Notepad as well as MiGraph. 

 

 

 

 

 

 

 

1.2.6.2 To DXF file 

Use “Edit > Write >> To DXF file” to convert the displayed plot to dxf file(.dxf) format.   
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Conversion procedure: 

1. Give the output dxf file name.  

2. Click OK to convert to Dxf file 

3. Open the file in AutoCAD 

 

1.2.7 Clear Graphs 

Use “Edit > Clear Graphs” or from toolbar buttons to remove graphs from the display. 
New x axis and y-axis selections should be made for plotting another set of curves. This option can 
be used when large numbers of curves are to be plotted from the same binary file 

 

1.2.8 Analyse Graphs 

MiGraph supports fourier analysis of selected graphs. Select the curve for which fourier analysis has 
to be done. Select the harmonic number from the list box. Select the inputs like either start from start 
window and number of samples or Start and End time. Click on compute to do the fourier analysis of 
the selected curve. 

 

 

 

 
A sample output is as shown below 

---------------------------------------- 
Fourier Analysis results  
---------------------------------------- 
Start Window                 : 1 
No. of Samples               : 32 
Positive minimum(All samples): 0.382680 
Positive maximum(All samples): 1.000000 
Negative minimum(All samples): -0.382680 
Negative maximum(All samples): -1.000000 
Average(from start window)   : 0.000000 

Harmonic Order               : 3 
Magnitude                    : 0.000000 
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RMS Value                    : 0.000000 
Thetha                       : 90.000000 

 

1.2.9  Math Operations 

Math operations can be performed on the selected curves. The new curve points obtained is 

= (a0+/*b0 x old curve point) 

   (a1+/*b1 x old curve point) 

Select the Curve, Give new graph title, x-axis title, y-axis title, a0, b0, a1 and b1.  

Click on add button, to add/modify the mathematical symbols 

Click on compute to create the new graph file. Save it in a new file. Open this file in MiGraph. 

 

 

1.2.10 Column Selection 

Often it is necessary to plot many curves to observe the variations in the system. A facility to plot all 
the related curve in a single click is provided. This option enables the Selection of columns with 
given offset. Select - Edit-Column Selections or click on   the following dialog box 
appears. 

Select the x-axis column number. Y axis starting column number, off set columns (by default it is 10 
which is appropriate for Transient stability graphs generated by MiP-PSCT) and the last column 
number.  

Click Ok to plot the selected curves. 

 

 

 

 

 

 

 

 

1.2.11 Source Name 
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The data source for the curves is a binary file. The option to change the source file is provided so 
that by changing the source file, it would allow to reuse the same graph definition file for a whole 
series of studies. For example, if 30 studies are done and for all of them you need to look at the 
same parameters (say voltages) you need only to copy the grp file to a new filename. Open the new 
grp file and change the source data file and without having to go through the process of selection 
again immediately get the same set of parameters graphed from the new source data file.  

 

 

 

 

 

 

 

 

 

 

 

 

 

1.2.12 Generate Graph Point 

This option is used to generate graph data file and to view the graph. Follow the steps 

Open a new file in Migraph. 

Select option from main menu Edit > Generate Graph Point > Graph Data. Following Dialog box 

will open. 

File Name: Give the file name to save the Graph Data text file by using the browse button.  

Graph Title: Give name for the graph 

X - Axis Title: Give title for the X-axis 

Y - Axis Title: Give title for the Y-axis 

X-Axis unit: Give the unit for X-axis 

Y -Axis unit: Give the unit for Y-axis 

X-Axis range: Give minimum range value and maximum range value  

Y-Axis range: Give minimum range value and maximum range value 

No. of Grid Lines: Mention the no. of grid lines. Click on OK. 

Graph with the given details will be opened. 

Double click LMB (Left Mouse Button) on the graph. Double click will go on generating points. 

Now select menu option Edit > Generate Graph to view the graph. 

Generated graph file can be saved with ‘.grp’ extension. 

 

1.2.13 Delete Curve 

In relay graph select the relay curve and click right mouse button (RMB) and select delete curve 
option from the menu. Or select menu Edit->delete curve option to delete the selected relay curve 

 

1.2.14 Delete fault line 
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In relay graph option to delete the fault line is available by selecting the fault line and click right 
mouse button (RMB) and select delete fault line option from the menu. Or select menu Edit->delete 
fault line option to delete the selected fault line 

 

1.3 View 

The View menu offers the following commands: 

 

1.3.1 Toolbar 

Use “View Toolbar” to display and hide the Toolbar, which includes buttons for some of the most 

common commands in MiGraph, such as File Open.  A check mark appears next to the menu item 
when the Toolbar is displayed.   

 

1.3.2 Draw Tool box 

Use “ViewDrawing Tool bar” to show or hide the basic drawing toolbar. This option will be either 

ON/OFF. If this option is ON, the toolbar is shown at left by default. Else the toolbar is hidden. The 
commands interfaced to the buttons placed on the toolbar from top to bottom order are: - 

Object Selection  

Line 

Rectangle 

Round Rectangle 

Square 

Diamond 

Ellipse 

Circle 

Arc 

Chord 

Pie 

Semi-Circle 

Sine Wave 

Polyline 

Polygon 

 

1.3.3 Status Bar 

Use “View  status Bar” to display and hide the Status Bar, which describes the action to be 

executed by the selected menu item or depressed toolbar button, and keyboard latch state.  A check 
mark appears next to the menu item when the Status Bar is displayed. 

 

1.3.4 Symbol 

Use “View  Symbol” to shows or hide the symbol over the curve.  To view symbol over the curve 

on choosing this option, each curve is assigned a symbol and curve is redrawn. This option helps 
while printing through a black & white printer. 
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1.3.5 Caption 

Use “View  Caption” option to view the relay name on the curve. This feature is recommended 

only for relay co-ordination curves. 

 

1.3.6 Zoom 

Use “View  Zoom” or    select on the toolbar to zoom the window. With this, it will be 
enlarged to a default scale. 

 

1.3.7 Trace 

Use  “View  Trace” to track the curves drawn. Press right arrow key to move forward. The curve 

value at that point is shown. Press left arrow key to move back. To jump between different curves 
use either up arrow or down arrow keys 

 

1.3.8 Semilog –X 

Use “View  Semilog-X” or the semilog-x tool bar button present at the left bottom of the screen to 
plot the graph in a semilog scale, i.e., X-axis in logarithm scale. 

1.3.9 Semilog -Y  

Use “View  Semilog-Y”   or the button provided on the left bottom toolbar on the screen to plot the 

graph in a semilog scale, i.e., Y-axis in logarithm scale. Log  
 

Use “View  Log” or from toolbar button provided on the left bottom of the screen to plot 
the graph in log scale, i.e., both X and Y-axis in logarithm scale 

  

1.3.10 Points 

Use”View->Points” or from toolbar to view the graph as poles and zeroes instead of 
continuous curve.   

 

1.3.11 MiSheet 

Use “View  Misheet” to display the sheet where the data (text matter) can be modified. This will 

pop up a sheet as shown. For large input file this operation is not recommended since it slows down 
the operation. 
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1.3.12 Physical 

When the Physical menu item is checked, the graph can be viewed in the original size irrespective 
of the window size. When unchecked, the graph will resize automatically to fit to the window size. 

 

1.3.13 Distance Relay 

To plot distance relay characteristics follow the steps. 

While invoking Graph from transient stability analysis dialog, select Line option 

On MiGraph select the required line’s R in pu along X-axis and X in pu along Y-axis. Then click plot 
button on MiGraph screen or select menu option Sheet >Plot. 

Then select View > Distance Relay to invoke the Select Distance Relay Graph File dialog.  Choose 

the Relay name from the combo box and click on OK to plot the corresponding distance relay 
characteristics on the graphs 

Distance relay zone wise entering time, Leaving time, Elapsed time and trip signal values are 
displayed on a text box on the left side of the graph. 

To plot the Distance relay characters from other file  

Click on browse and choose the corresponding. Drc file and choose the relay name corresponding 
to the relay for which the characteristic is required. 

A sample characteristic graph is shown below. 

 

 

 

 

 

 

 

1.3.14 Normalised Curve 
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Select this option from menu View Normalised Curves or click on tool bar  with this option, for a 
particular fault current, the operating time (along with discrimination time) and the fault current seen 
by backup relays are displayed on the graph. The fault line can be selected and moved. With the 
fault line intersecting the curves will show fault current seen by the relays and the discrimination time 
between the relays 

 

 

 

 

 

 

 

1.4 Sheet 

1.4.1 Plot 

Use “Sheet  Plot” or from the toolbar button present at the left bottom of the screen to 

update the plots in the view. By clicking this button, whole graph will be redrawn again depending on 
the current selection/setting. If no variable is selected to draw by default program selects the first 
variable as X-axis and second variable as Y-axis variable and curve is drawn. 

 

1.4.2 X-axis 

Use  “Sheet  X-axis” or          from the toolbar button present at the left bottom of the screen to 
select the independent X-axis.   To select the X axis column in the sheet view (right second pane). 
By default first column will be selected for independent axis or the user can select anyone from the 
list. 

 

 

 

1.4.3 Y-axis 

Use “Sheet  Y- axis” or from the toolbar button present at the left bottom of the 

screen to select the dependent Y-axis.  To select the Y axis column in the sheet view 
(right second pane). By default, first column will be selected for independent axis or the user can 
select anyone from the list. 

 

1.4.4 To get the multiple independent axis 

Use “Sheet  Multi X-Y” to select multiple groups of dependent and independent columns. User is 
able to select new groups by pressing the new independent group button (displayed in right 
second pane after the selection of Multi X-Y). Each group will be having one independent and any 

number of dependents can be selected. 
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1.5 Format   

The format menu offers following commands 

 

 

 

 

 

 

 

 

 

1.5.1 Curve 

Use “Format  Curve” to change curve attributes. On selecting this option, a dialog box will be 

popped up as shown.  On the dialog box select one legend of the curves listed to change the 
different attributes of the curve.  Curve color can be changed by clicking the box to the right of the 
text color.  On clicking this Box, Color dialog box will be popped up. The curve legend can be 
changed. 

 

1.5.2 Background                                         

Use “Format  Background” to change background color of the graph.  On selecting this option, a 

dialog box is popped up as shown.  Select any of the colors available on the dialog box and click OK 
button to observe the changes. 

 

 

 

 

 

 

 

 

 

 

 

1.5.3  Axis 

Use “Format  Axis” to format either X or Y-axis.  On selecting this option, a dialog box is 
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popped up as shown.  On this dialog, check X-axis button if X-axis has to be formatted. Check Y-
axis button if Y-axis has to be changed.  After selecting the axis, attributes like thickness, color, 
alignment of the axis, color, alignment, precision of the axis label, font size, style, color. Number of 
tick marks, number of grid lines and color of them can also be changed for each of the axis.  After 
making the desired changes click, OK button to the see the changes. If CANCEL button is clicked, 

changes are ignored.   

 

1.5.4 Text box 

Use “Format  Text box” to change font color, style and size of a text.  On selecting this option, a 

dialog box is popped up as shown.  Select the desired font types, font color, and font size and click 
OK to get the desired changes. 

 

1.5.5 Range   

Use “Format  Range” or    from the left bottom screen toolbar to change the range. This 
will display a dialog box to change the min and max value of the X & Y-axis with number of tick 
marks required.  To perform this operation, choose menu option Format->Range or click button 
provided on the toolbar.  On the dialog box change either X-axis minimum and maximum values or 
Y-axis minimum and maximum values and click OK.  On clicking OK button, the curves will redraw 
to the specified range. 

 

1.6 Draw 

This menu offers following options 

 

1.6.1 Text Box  

Use “Draw  Text Box” or from the toolbar and click on the screen where the text box 
should be drawn. On releasing the Left mouse Button, a text editor dialog is popped up in which the 
text can be edited. To modify or delete the text double click on the text box to invoke the text editor 
dialog 

 

 

 

1.6.2 Grid 
1.6.2.1 X-axis 

Use “Draw  Grid X-axis” command or         toolbar button from the left bottom screen, the 
grids parallel to X axis will be displayed. This depends on the current scale setting i.e. whether linear 
or log.  

1.6.2.2 Y-axis 

Use “Draw  Grid Y-axis” command or toolbar button from the left bottom screen, the 
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grids parallel to Y axis will be displayed. This depends on the current scale setting i.e. whether linear 
or log.   

 

1.6.3 Line Graph 

Use “Draw  Line Graph” command or   toolbar button from the top screen, the Line graph will be 

displayed.  

 

1.6.4 Bar Graph 

Use “Draw  Bar Graph” command or     toolbar button from the top screen, the Bar graph will be 

displayed.  

 

1.6.5 Stacked Bar Graph 

Use “Draw  Stacked Bar Graph” command or    toolbar button from the top screen, the Stacked Bar 
graph will be displayed. 

 

1.6.6 Pie Graph 

Use “Draw  Pie Graph” command or   toolbar button from the top screen, the Pie graph will be 

displayed.  

 

1.6.7 3D Bar Graph 

Use “Draw  3D Bar Graph” command or   toolbar button from the top screen, the 3D Bar graph 

will be displayed.  

 

1.6.8 3D Stacked Bar Graph                             

Use “Draw  3D Stacked Bar Graph” command or toolbar button from the top screen, the 3D 
Stacked Bar graph will be displayed. 

 

1.6.9 3D Pie Graph 

Use “Draw  3D Pie Graph” command or  toolbar button from the top screen, the 3D Pie graph  will 

be displayed.  

 

 

1.6.10 Line Graph (Tape Graph) 

Use “Draw  3D Stacked Bar Graph” command or toolbar button from the top screen, the Line 

graph (Tape Graph) will be displayed.  

 

1.6.11 Selection 
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 If this selection mode is ON, then user can carry out operations like move, resize cut, copy and 
paste etc. 

 If this selection mode is OFF, then user can carry out operations like panning, zooming and to 
note the details of an object (in which layer it is, thickness etc.)  

 

1.6.12 Slant Line 

Use “DrawHorz/Vert Line” OR       from a Draw toolbar on the LHS of the screen. This 
option is used to draw a line between start point to end point and to fit inside a rectangle formed by 
start point and end point. The line can be resized by dragging the handle on the rectangle box. The 
handles are highlighted whenever an object is selected for resizing or moving. If the Orthogonal flag 
is ON, the line will be drawn in Horizontal / Vertical fashions only. Turn OFF the Orthogonal flag to 
draw a line at any desired angle. 

 

1.6.13 Rectangle 

Use “DrawRectangle” OR   from the Draw toolbar on the LHS of the screen. This option is 
used to draw a rectangle between start point to end point and to fit inside a rectangle formed by start 
point and end point. The rectangle can be resized by dragging a handle on the rectangle box. The 
handles are highlighted whenever an object is selected for resizing or moving. Procedure is similar 
to slant line drawing. 

 

1.6.14 Round Rectangle 

Use “DrawRound Rectangle” OR   from the Draw toolbar on the LHS of the screen. This option 

is used to draw a round rectangle between start point to end point and to fit inside a rectangle 
formed by start point and end point. The round rectangle can be resized by dragging a handle on the 
rectangle box. The handles are highlighted whenever an object is selected for resizing or moving. 
Procedure is similar to slant line drawing.  

 

1.6.15 Square 

Use “DrawSquare” OR from the Draw toolbar on the LHS of the screen. This option is used to 
draw a square between start point to end point and to fit inside a rectangle formed by start point and 
end point. The square can be resized by dragging a handle on the rectangle box. The handles are 
highlighted whenever an object is selected for resizing or moving. 

 

1.6.16 Diamond 

Use “DrawDiamond” OR from Draw toolbar on the LHS of the screen. The option is used 
to draw a diamond between start point to end point and to fit inside a rectangle formed by start point 
and end point. The diamond can be resized by dragging a handle on the rectangle box. The handles 
are highlighted whenever an object is selected for resizing or moving. Procedure is similar to slant 
line drawing. 

 

 

 

 

1.6.17 Ellipse 

Use “DrawEllipse” OR from Draw toolbar on the LHS of the screen. This option is used 
to draw an ellipse from start point to end point and to fit inside a rectangle formed by start point and 



MiP-PSCT                                                                                                      Graph utility User Manual 

 

 

Power Research and Development Consultants Pvt. Ltd. Page 22 
 

 

end point. The ellipse can be resized by dragging a handle on the rectangle box. The handles are 
highlighted whenever an object is selected for resizing or moving. Procedure is similar to slant line 
drawing. 

 

1.6.18 Circle 

Use “DrawCircle” OR from Draw toolbar on the LHS of the screen. This option is used to 
draw a circle from start point to end point and to fit inside a rectangle formed by start point and end 
point. The circle can be resized by dragging a handle on the rectangle box. The handles are 
highlighted whenever an object is selected for resizing or moving. Procedure is similar to slant line 
drawing. 

 

1.6.19 Arc 

Use “DrawArc” OR from Draw toolbar on the LHS of the screen. The option is used to draw an arc 
from start point to end point and to fit inside a rectangle formed by start point and end point. The arc 
can be resized by dragging a handle on the rectangle box. The handles are highlighted whenever an 
object is selected for resizing or moving. Procedure is similar to slant line drawing. 

 

1.6.20 Chord 

Use “DrawChord” OR from Draw toolbar on the LHS of the screen. This option is used to draw a 

chord from start point to end point and to fit inside a rectangle formed by start point and end point. 
The chord can be resized by dragging a handle on the rectangle box. The handles are highlighted 
whenever an object is selected for resizing or moving. Procedure is similar to slant line drawing. 

 

1.6.21 Pie 

Use “DrawPie” OR from Draw toolbar on the LHS of the screen. This option is used to 
draw a pie from start point to end point and to fit inside a rectangle formed by start point and end 
point. The pie can be resized by dragging a handle on the rectangle box. The handles are 
highlighted whenever an object is selected for resizing or moving. Procedure is similar to slant line 
drawing. 

 

1.6.22 Semicircle 

Use “DrawSemicircle” OR from Draw toolbar on the LHS of the screen.  This option is used to 

draw a semi-circle from start point to end point and to fit inside a rectangle formed by start point and 
end point. The semi-circle can be resized by dragging a handle on the rectangle box. The handles 
are highlighted whenever an object is selected for resizing or moving. Procedure is similar to slant 
line drawing. 

 

1.6.23 Sine Wave 

Use “DrawSine wave” OR from Draw toolbar on the LHS of the screen. This option is 
used to draw a sine wave from start point to end point and to fit inside a rectangle formed by start 
point and end point. The sine wave can be resized by dragging a handle on the rectangle box. The 
handles are highlighted whenever an object is selected for resizing or moving. Procedure is similar 
to slant line drawing. 

 

1.6.24 Polyline 
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Use “DrawPolyline” OR from Draw toolbar on the LHS of the screen. To draw a Polyline from 

start point to intermediate points till endpoint and to fit inside a rectangle formed by a polygon points. 
The Polyline can be resized by dragging a handle placed along the polygon points.The handles are 
highlighted whenever an object is selected for resizing or moving.   If the Orthogonal flag is ON, 
polygon will be drawn with straight lines. Orthogonal flag is OFF to draw a Polyline with inclined 
lines. With Orthogonal mode ON, when a point is touched to move, the cursor shape is changed to  
plus  and  the  touched  point  is aligned  in X  or Y  direction  with  respect  to  previous  point  
depending  on  whether  the  distance  along  X or Y direction is more. Procedure is similar to slant 
line drawing. 

 

1.6.25 Polygon 

Use “DrawPolygon” OR from Draw toolbar on the LHS of the screen. This option is used to draw 

a polygon from start point to intermediate points till end point and to fit inside a rectangle formed by 
polygon points. The polygon can be resized by dragging a handle placed along the polygon points. 
The handles are highlighted whenever an object is selected for resizing or moving. If the Orthogonal 
flag is ON, polygon will be drawn with straight lines (Horizontal / Vertical lines only). Orthogonal flag 
is OFF to draw a polygon with inclined lines. With Orthogonal mode ON, when a point is touched to 
move, the cursor shape is changed to plus and the touched point is aligned in X or Y direction with 
respect to previous point depending on whether the distance along X or Y direction is more. 

 

1.6.26 Fault Line: 

Select the option from tool bar  or Menu option Draw-> Fault Line. This draws a perpendicular 
line on the graph. When it is moved on the relay graph it shows Fault current at the top. For that fault 
current at relay intersection points shows relay operating time and the discrimination time of relays 
curve. 

 

 

 

 

 

 

 

 

1.7 Set Menu 

1.7.1 Orthogonal Mode 

This Option is used as a control parameter while drawing an object, object resize and moving 
object(s). The usage is either ON or OFF, If the flag is ON, the status bar pane text is set to “Ortho” 
else the pane is blank. A part of status bar showing the Ortho flag ON is shown in figure. 

Usage while drawing an Object          

When the flag is ON and while drawing a connecting line between any two points, the two points are 
joined by a Horizontal or Vertical line based on whether distance between two points is more along 
X axis or Y axis. 

                                    

age while resizing an Object                         

When an object is selected for resizing, if user tries to move any handle with the mode ON, the 
handle is moved either along X  axis or Y axis based on the maximum movement is along X  axis or 
Y axis. The rectangle object is redrawn as a square and  an ellipse object is redrawn as a circle. 
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Line 5: Usage while moving object(s)  

Select Object or Objects to move only one object or a group of objects. Holding down mouse LMB 
on one of the selected object move the mouse to desired location. The selected objects are moved 
either X or Y direction, depending on the maximum amount of X or Y displacement. 

 

1.7.2 Rotate 

Rotates the selected object by 90 degrees in clockwise direction 

 

Relay setting details in Graph 

Click on a relay displays the relay details like over current and instantaneous setting details on the 
graph these text boxes can be moved to required location in the graph 

 

 

 

 

 

 

1.8 Relay Curve Dragging 

With the above option, by clicking and dragging the particular relay curve, the change in settings of 
particular relay is displayed. However with this option the setting given in data field of particular relay 
remains unchanged. 

 

Step 1 

 

 

 

 

 

 

 

 

 

 

 

 

Step 2 
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1.9 Provision for selection of all relay pairs displayed in relay 
graph. 

Step 1  

 

 

 

 

 

 

 

 

 

Step 2 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note: The “select all” option considers only 20 relay pairs at a time. 

Option to clear relay groups and clear the selection of all relays present in the graph are provided. 
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1.10  Window 

The Window menu offers the following commands, which enable you to arrange multiple views of 
multiple documents in the application window: 

 

1.10.1 New Window 

Use this command to open a new window with the same contents as the active window.  You can 
open multiple document windows to display different parts or views of a document at the same time.  
If you change the contents in one window, all other windows containing the same document reflect 
those changes.  When you open a new window, it becomes the active window and is displayed on 
top of all other open windows. 

 

1.10.2 Cascade 

Use this command to arrange multiple opened windows in an overlapped fashion. 

 

1.10.3 Tile 

Use this command to arrange multiple opened windows in a non-overlapped fashion. 

 

1.10.4 Arrange Icons 

Use “Tile  Arrange Icons” command to arrange the icons for minimized windows at the bottom of 

the main window.  If there is an open document window at the bottom of the main window, then 
some or all of the icons may not be visible because they will be underneath this document window. 

 

1.10.5 Split 

Use “Tile  Split” command to split the active window into panes.  You may then use the mouse or 

the keyboard arrows to move the splitter bars.  When you are finished, press the mouse button or 
enter to leave the splitter bars in their new location.  Pressing escape keeps the splitter bars in their 
original location. 

 

1.10.6 Window 

Graph utility displays a list of currently opened document windows at the bottom of the Window 
menu.  A check mark appears in front of the document name of the active window.  Choose a 
document from this list to make its window active. 
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1.11  Show 2ndPane 

Use the toolbar button to show/hide the second pane. The pane is not view if no file is imported. 

Example 

Create the following text file using ASCII file editor tool or Notepad and plot the graph by selecting 
X-axis as angle and Y-axis as R-Y-B phase voltages. 

 

 

 

 

 

 

 

 

 

 

 

Typical 3 phase wave 

4 

Angle 

R-Phase 

Y-Phase 

B-Phase 

Angle in degrees 

Voltage in p.u 

Voltage in p.u 

Voltage in p.u 

0 0.0 -0.866 0.866 

30 0.5 -1.0 0.5 

60 0.866 -0.866 0 

90 1.0 -0.5 -0.5 

120 0.866 0 -0.866 

150 0.5 0.5 -1.0 

180 0 0.866 -0.866 

210 -0.5 1.0 -0.50 

240 -0.866 0.866 0 

270 -1.0 0.5 0.5 

300 -0.866 0 0.866 

330 -0.5 -0.5 1.0 

360 0 -0.866 0.866                                                     

The result is as shown above. 
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