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1 Introduction 

This manual provides information on the MiCtViewer module. In this module an 
option is provided for the user to view the Comtrade files both in numerical and 
graphical way. 

The Comtrade viewer reads the .dat file and .cfg file for the inputs and it displays 
the samples both in numerical as well as graphical format.  The data display offers 
a high-resolution graphical interface for displaying, analyzing and manipulating 
analog and digital channels of an oscillography record or a periodic load file. 
Displayed channels are marked, zoomed, numerically processed and summarized. 
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2 Menus 

2.1 File Menu 

The file menu consists of the following options as shown in figure below: 

 

Figure 1: File Menu 

2.1.1 New 

On the file menu, Click  File > New to create a new file. The shortcut for this option 
is “Ctrl+N” 

 

Figure 2: New 

2.1.2 Open 

On the file menu, Click  File > Open to open a file from the exisiting folder. The 
shortcut for this option is “Ctrl+O” 

 

Figure 3: Open 

2.1.3 Close 

On the file menu, Click  File > Close  to close the application. 

 

Figure 4: Close 



MiP-PSCT                                                                                                                                       COMTRADE Viewer User Manual 

 

Power Research and Development Consultants Pvt. Ltd. Page 8 
 

2.1.4 Save As 

 

Figure 5: Save As 

On the file menu, Click  File > Save As  to save the file into different file formats. 
The options available are; 

 Bitmap 

 JPEG 

 Generate image 

Note: You can save the opened file in .bmp or .jpeg format. If you click on the 
analog section and do a save as it will save only the analog screen. If you click on 
the digital section it saves the digital section. 

Now to save the screen in .bmp format you need to do the following:  

Bitmap: Open a .cfg file go to File > Save as and select bitmap. The following 
dialog box appears: 

 

Now enter a file name and click save. The image is saved in .bmp format as shown 
below: 
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Figure 6: .cfg File in .bmp Format (Analog Section) 

Open a .cfg file and put the cursor on the digital section and save as .bmp format. 
The image is saved as shown below: 

 

Figure 7: .cfg File in .bmp Format (Digital Section) 

 

 
 

JPEG: Open a .cfg file go to File > Save as and select  .jpeg format. The following 
dialog box appears: 
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Figure 8: .cfg File Saved in .jpeg Format 

The image is saved as shown below: 

 

Figure 9: Image Saved in .jpeg Format 

Generate Image: Open a .cfg file go to File > Save as and select generate image, 
the following window appears: 
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Figure 10: Generate Image – Save Image As 

In this screen the data is displayed for both analog and digital channel. User has the 
option to select or de-select the particular channels. The fields for Analog and 
Digital channels are described below: 

Analog Channels: Analog channels have the following attributes. 

Channel ID: Channel ID is the number of the channel. 

Channel Name: The respective name for the channel ID. 

Channel Unit: According to the channels, unit is displayed. 

Status: The status of the channel is shown in form of a check box which user can 
select and de-select. The option for select or deselect is provided for channel 
selection. As a user you may not need all the channels while generating image. So 
in that case you can use this option. 

Digital Channels: Digital channels have the following attributes. 

Channel ID: Channel ID is the number of the channel. 

Channel Name: The respective name for the channel ID. 

Status: The status of the channel is shown in form of a check box which user can 
select and de-select. The option for select or de-select is provided for channel 
selection. As a user you may not need all the channels while generating image. So 
in that case you can use this option. 

Save Image As: User can select the option to save the file into image format. The 
options available are .bmp and .jpeg. 
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Phasor: The options to select in the phasor window are None, Voltage, Current, 
Voltage and Current and all. Depending on the selection type the images are 
generated. 

Image Path: Click this button , the following dialog box appears: 

 

Enter the file name and click open. This will store the path where the image is going 
to be stored. 

Generate: Click this button to generate the image. 

View: Select a file and click view button to see the image. 

Cancel: Click this button  to cancel the above actions. 

Note: For both analog and digital channels the information comes from the .cfg 
files. 

2.1.5 Print 

On the file menu, Click  File > Print  to print the Comtrade viewer screen. The 
shortcut for this option is “Ctrl+P” 

 

Figure 11: Print 

2.1.6 Print  Preview 

On the file menu, Click  File > Print  Preview to have a print  preview of the 
comtrade viewer. 
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Figure 12: Print Preview 

2.1.7 Print Setup 

On the file menu, Click  File > Print  Setup to have a print set up for the comtrade 
viewer. 

 

Figure 13: Print Setup 

2.1.8 Recently Opened Files 

Recently opened files. It lists maximum of ten recently opened files as shown 
below: 

 

Figure 14: Recently Opened Files 

2.1.9 Exit 

On the file menu, Click  File > Exit to come out of the application. 
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Figure 15: Exit 
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3 View 

3.1 View Menu 

The view menu consists of the following options as shown in figure below: 

 

3.1.1 Toolbar 

On the View menu,select  View > Toolbar to activate the toolbar as shown in the 
figure below: 

 

Figure 16: Toolbar 

Now all the options in the tool bar are active.  De-selecting the toolbar option takes 
out the tool bar from the active window. 

3.1.2 Status Bar 

On the View menu, select  View > Status bar to activate the Status Bar as shown 
in the figure below: 

 

Figure 17: Status Bar 

Now all the options in the status bar are active De-selecting the Status Bar option 
takes out the tool bar from the active window. 

.   

3.1.3 Sample Navigation Bar 

On the View menu, Select View > Sample Navigation Bar to activate the Sample 
Navigation Bar as shown in the figure below: 

 

Figure 18: Sample Navigation Bar 

The sample navigation bar appears below the tool bar. 

Sample: Sample  is read from the .cfg files. When user selects sample, the 
reference axis moves based on samples. Sample moves by one number at a time. 
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For example - if the sample number is 1 and move next is clicked, the sample 
number is increased by 1 and hence displays 2. This sample number depends on 
the .cfg files. 

Cycle: A cycle consists of fixed number of samples. When the user selects cycle, 
the analog and digital data windows are  moved by one cycle at a time. For 
example if the cycle number is 1 and you click move next the next cycle will jump to 
21. Here the sample per cycle value is 20. This cycle number depends on the .cfg 
files. 

From Sample to To Sample: From sample and to sample 

 reflects the sample number in the field. Here sample or 
cycle number gets displayed wherever the reference axis is clicked.. User can enter 
the desired number and press tab. The reference axis will move to that particular 
sample/cycle number. 

Move First: Clicking this  button moves the reference axis to the first 
sample/cycle. 

Move Previous: Clicking on this  button moves the reference axis to the 
previous sample/cycle. 

Move Next: Clicking on this  button moves the reference axis to the next 
sample/cycle.  

Move Last: Clicking on this  button moves the reference axis to the last 
sample/cycle. 

Trigger Point: Clicking on this  button moves the reference axis to the trigger 
point. 

3.1.4 Configuration File 

On the View menu, click Configuration File which brings the following page: 
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Figure 19: Configuration File 

3.1.5 Data File 

On the View menu, click Data File which brings the following page: 

 

Figure 20: Data File 
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3.1.6 Report 

On the View menu, click on Report option which brings the following page: 

 

Figure 21: Report 

This report is generated for the opened file in the current window. The summary of 
the report includes: 

 File information 

 Summary of analog channels 

 Digital channel data 

 Digital channel sequence events 

 Images of analog, digital and phasor section  
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Setting: On this screen click the settings button which brings the following page: 

 

Figure 22: Report Output Configuration 

User can define their own report output configuration. 

Report Types:  The following report types are avaliable: 

 

Figure 23: Report Types 

HTML Report: 

Select HTML Report.  

The application prompts with a message as shown below: 

 

Figure 24: Output File Name 

User can select the location by clicking the browse button & save the File. 

Note: Same screen will be displayed when user selects other options say PDF 
Report, DOC Report, JPG Report & TIFF Report options. 

HTML report is displayed as shown below: 
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Figure 25: Report in HTML Format 

PDF Report: 

When PDF Report selected, report will be displayed  in PDF format. 

 

Figure 26: Report in PDF Format 

DOC Report: 

When  DOC Report selected, report will be displayed in doc format. 
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Figure 27: Report on Document Format 

JPG Report: 

When JPG Report selected, report will be displayed in .JPG format. 

 

Figure 28: Report in .JPG Format 

TIFF Report: 

When TIFF Report selected, report will be displayed in TIFF format. 
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Figure 29: Report in TIFF Format 

Xls Report: When Xls Report selected, report will be displayed in Xls format. 

 

Figure 30: Report in XLS Format 

 

Txt Report: When Txt Report selected, report will be displayed in .Txt format. 
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Figure 31: Report in Txt Format 

Print: Click this button which brings the following window: 

 

Figure 32: Print Properties 

Name: Here the user can select the available printer name from the drop-down 
combo box.  

Print range & Copies: User can select all the pages or selected page numbers and 
can select the number of copies for print. Click ok to print and click the cancel 
button to cancel the print. 

Close: Click close to exit the view report screen.  

Edit Comments: Click on the edit comments buttoon,  which brings a small pop up 
window as shown below: 
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Figure 33: Edit Comments 

You can enter the comments here and click update. The comments will be updated 
in the report. 

Note: In comtrade viewer module there are four types of users. For the users who 
have permissions only to view the report, the edit comments button will be disabled.   

3.1.7 Analog Plot 

On the View menu, select Analog Plot to view only analog channels as shown in 
figure below: 

 

Figure 34: Analog Plot 

On  De-selecting the Analog Plot option takes out the Analog plot section from the 
active window. 

 

3.1.8 Digital Plot 

On the View menu, Select Digital Plot to view only digital channels as shown in 
figure below: 
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Figure 35: Digital Plot 

On  De-selecting the Digital Plot option takes out the Digital Plot section from the 
active window. 

 

3.1.9 Phasor 

On the View menu, click Phasor which brings the figure below: 

 

Figure 36: Phasor 

On  De-selecting the Phasor Plot option takes out the Phasor plot section from the 
active window. 

3.1.10 Properties 

On the View menu, click properties which brings the figure below: 
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Viewer name: displays all sections of Comtrade viewer  

Back Ground color: user can select the back ground color for the section   

 

On the Graph menu, Select View> View Properties as shown below: 

 

Following page appears: 
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If the use wants to change any particular section  color, then select the particular 
section and double click on the color. Which brings the color palette box as shown 
below: 

 

Here user can select any color and click ok. 
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Now the color for that particular section is changed  and is reflected  in comtrade 
viewer. 

 

 

4 Graph 

4.1 Graph Menu 

The view menu consists of the following options as shown in figure below:  

 

Figure 37: Graph Menu 
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4.1.1 Fit to View Width 

On the Graph menu, select Fit to View Width which brings the following screen: 

 

Figure 38: Fit to View Width 

Now the analog and digital plots are squeezed to width.  It has got a toggle option. 
On de-selection of this option, width will be retained as default: 

 

Figure 39: Fit to View Width – De-selection 
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4.1.2 Fit to Minimum Height 

On the Graph menu, click Fit to Minimum Height which brings the following page: 

 

Figure 40: Fit to Minimum Height 

Now the analog and digital plots are squeezed to height. It has got a toggle option. 
On de-selection of this option, height will be retained as default: 
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Figure 41: Fit to Minimum Height – De-selection 

4.1.3 Tabular Data Show 

On the Graph menu, select Tabular Data Show which brings the following page: 

 

Figure 42: Tabular Data Show 
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On de-selection, tabular data option brings the following page: 

 

Figure 43: Tabular Data De-select 

Note: When the tabular data button is in de-select mode it hides the data. 

4.1.4 Boundary Clip 

On the Graph menu, select Boundary Clip which brings the following page: 
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Figure 44: Boundary Clip 

Clip boundary is a toggle button. User can select or de-select the button.  

Clip boundary – on: Overlapped portion is clipped.  
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Figure 45: Clip Boundary - on 

Clip boundary – off: Overlapped portion is Unclipped. 

 

Figure 46: Clip Boundary - Off 

4.1.5 Scale Type 

There are four scale types available. Those are: 

 Axis Y: When you choose this option, the selected channels are scaled/re- 
scaled vertically. 

 Axis X right: When you choose this option, all the channels are scaled 
towards right side. 

 Axis X left: When you choose this option all the channels are scaled 
towards left direction. 

 Axis X left and right: When you choose this option, all the channels are 
scaled towards both left and right. 

 Scale plus: this option all option work according to the selected axis type. 

 Scale minus:  this option all option work according to the selected axis type. 

 Scale to normal: On click of option, it will set to normal. 

4.1.6 Zoom Plot Area in Percentage 

On the Graph menu, click Zoom Plot Area in Percentage as shown below: 
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Figure 47: Zoom Plot Area in Percentage 

The percentage of the plot area is zoomed as per the selection. 

4.1.7 Config Channel Color 

On the Graph menu, Select Config > Channel Color as shown below: 

 

Figure 48: Config Channel Color 

Following page appears: 
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Figure 49: Config Channel Colors 1 

If the use wants to change any particular analog / digital channel color, then select 
the particular channel and double click on the color. Which brings the color palette 
box as shown below: 

 

Figure 50: Color 

Here user can select any color and click ok. 

Now the color for that particular channel is changed  and is reflected  in comtrade 
viewer. 
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Figure 51: Changed Color 

4.1.8 Channel Visibility 

On the Graph menu, click Config > Channel Visibility which brings the following 
page: 
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Figure 52: Channel Visibility 

 

The fields for Analog and Digital channels are described below: 

Analog Channel: Under the Analog Channles following attributes are available: 

ID: This is the ID for the analog channel. 

Channel Name: Channel name is displayed as per the opened .cfg file. 

Status: This is the status of the channel. If selected by user it displays on the 
Comtrade Viewer main window. If de-selected then it  will not be displayed in the 
comtrade viewer window. 

Digital Channel: Under the digital  channels following attributes are available: 

ID: This is the ID for the digital channel. 

Channel Name: Channel name is displayed as per the opened .cfg file. 

Status: This is the status of the channel. If selected by user it displays on the 
Comtrade Viewer main window. If de-selected then it  will not be displayed in the 
comtrade viewer window. 

 

Here the user can select or de-select the required channels. If you want to de-select 
few channel ID’s then clear the check boxes for  those particular ID’s. For example 
in the above screen shot user does not want the first and second channel to appear 
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on the main window. In that case clear the check boxes for  the channels as shown 
below: 

 

Figure 53: Select/Deselect Channel 

and click OK. 

On click of OK the De-selected channels will be hidden. 
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Figure 54: Selected Channels 

 

Figure 55: 1 & 2 Channels Hidden 

4.1.9 Tabular Attributes 

On the Graph menu, click Config > Tabular Attributes which bring the following 
page: 
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Figure 56: Config Table 

The fields for Analog Tabular header and Harmonic section are described below: 

SL. No: This is the serial number. The number of rows/coloumns allowed in this 
table is ten. 

Default  Column Header: Default  column header is read-only. 

Config  Column Header: User can change the config  column header.  Maximum 
of 10 entries are allowed in this column. 

No. of Decimal Places: Application accepts up to 4 decimal points. If the value is 
greater then 4 and less then 1 then it will not accept. 
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Visibility: User can select and clear the check boxes for  the visibility on comtrade 
viewer. 

Set to Default: Used to retain the default values. 

Ok: Click this to make the changes. 

Cancel: Click the cancel button to cancel the changes. 

Note: Same is applicable for harmonic section. Config  Column Header is allowed 
to  accept upto 25 characters,Under harmonic section user can select and view only 
two harmonics on comtrade viewer at a time.   

4.1.10 View Harmonics 

On the Graph menu, select View Harmonics. 

 

Figure 57: View Harmonics 

The following screen appears as shown below: 

 

Figure 58: View Harmonics Table 

Sample: When sample is selected the harmonics values in the table are displayed 
according to sample. Sample moves by one number at a time. For example if the 
sample is at 1 and you click move next it will go to 2. 

Cycle: When cycle is selected the harmonics values in the table are displayed 
according to cycle. When the user selects cycle, one cycle moves at a time. For 

Comment [p1]: Need to update as per 
the new changes 
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example if the cycle number is 1 and you click move next the next cycle will jump to 
21 if number of samples per cycle is 20.  

From Sample to To Sample: From sample and to sample 

 reflects the sample number/cycle number in the 
field. Enter specific sample number or cycle number and click on tab it will go to 
particular sample/cycle. 

Total Samples: It displays the total samples as per the.cfg files. Total number of 
samples recorded by the device in comtrade file. 

Samples/cycle: It displays the samples/cycles as per the .cfg file.  

Move First: Clicking this  button takes you to the first sample/cycle. 

Move Previous: Clicking on this  button takes you to the previous 
sample/cycle. 

Move Next: Clicking on this  button takes you to the next sample/cycle.  

Move Last: Clicking on this  button takes you to the last sample/cycle. 

Trigger Point: Clicking on this  button takes you to trigger the point. 

Close: Clicking on close button closes the window.  

4.1.11 View Comparison 

On the Graph menu, select View Comparison 

 

Figure 59: View Comparison 

View comparison option allows the user to see the comparison between the 
channel attributes. User can select any number of channels to view the comparison.  

Now to view comparison select two channles from .cfg file as shown below: 
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Figure 60: View Comparison 1 

Once the channels are selected go to Graph > View Comparison which brings the 
following page: 

 

Figure 61: View Comparison 2 

In this page the comparison of the two channels  has  been displayed. 

Note: This option should get enabled only when user selects the channel on 
comtrade viewer. 

4.1.12 View Compuataional 

On the Graph menu, select View Computational 
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Figure 62: View Comparison 

View Compuation option allows the user to see the compuation waveforms. User 
can select any number of channels to view the Computaional.  

Now to view computaional select one Analog and Two digital channles On 
comtrade viewer shown below: 

 

Figure 63: View Computational 

 

Once the channels are selected go to Graph > View Computational which brings 
the following page: 
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Select one or more select check box’s and click on Ok button which brings the 
following page :  

 

In this page the Compuataional view  has  been displayed. 

Note: This option should get enabled only when user selects the channel on 
comtrade viewer. 
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4.1.13 Show Labels 

This is a toggle button. Selecting show label option will display the maximum and 
minimum value for all the channels as shown below: 

 

Figure 64: Labels 

De-selecting the Show Label option takes out the  Label data from the active 
window. 

4.1.14 Mouse Action - Scroll view 

Selecting this option  scrolls the comtrade viewer window vertically. 

4.1.15 Mouse Action  - Scroll reference 

Selecting  this option  scrolls Reference axis on comtrade viewer. 

Note: Both the buttons cannot work  simultaneously. 

4.1.16 Show x-y Axis Tool tip 

Selecting  this option  tool tip box is displayed on comtrade viewer. 
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4.1.17 View Analog Tabular Data 

On the Graph menu, select View Analog Tabular Data. The following window 
appears: 
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Figure 65: View Analog Tabular Data 

Sample: Sample  is read from the .cfg files. When user selects sample, the 
reference axis moves based on samples. Sample moves by one number at a time. 
For example - if the sample number is 1 and move next is clicked, the sample 
number is increased by 1 and hence displays 2. This sample number depends on 
the .cfg files. 

Cycle: A cycle consists of fixed number of samples. When the user selects cycle, 
the analog and digital data windows are  moved by one cycle at a time. For 
example if the cycle number is 1 and you click move next the next cycle will jump to 
21. Here the sample per cycle value is 20. This cycle number depends on the .cfg 
files. 

From Sample to To Sample: From sample and to sample 

 reflects the sample number in the field. Here sample or 
cycle number gets displayed wherever the reference axis is clicked.. User can enter 
the desired number and press tab. The reference axis will move to that particular 
sample/cycle number. 

Move First: Clicking this  button moves the reference axis to the first 
sample/cycle. 

Move Previous: Clicking on this  button moves the reference axis to the 
previous sample/cycle. 

Move Next: Clicking on this  button moves the reference axis to the next 
sample/cycle.  
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Move Last: Clicking on this  button moves the reference axis to the last 
sample/cycle. 

Trigger Point: Clicking on this  button moves the reference axis to the trigger 
point. 

              Export Brows button: Click on Export button which brings the following window    

                              
Select the XLS file and click on Ok button  

Export button: Click on Export button export the selected channel data to the XLX 
sheet  

View: Click on View button opens the Exported Data 

Analog tabular data shows the computed values of the channels. The table is 
having ten columns and those are: 

 Title: Title is the user defined naming convention for the channel as per the 
.cfg file 

 Units:  Unit of the particular channel. 

 InstValue: The instant value in the selected cycle. 

 DFT Peak: DFT Peak is the peak magnitude calculated for one cycle from 
the reference. 

 RMS: This is the RMS value for fundamental. 

 Phase: This is the vector phase angle.  

 InstMaxPeak:  The positive peak value in the selected cycle. 

 InstMinPeak: The negative peak value in the selected cycle.   

 MAXPeak:  MaxPeak is the maximum positive Instantaneous value of the 
corresponding channel for the entire recorded period. 

 MINPeak: MinPeak is the Minimum negative Instantaneous value of the 
corresponding channel for the entire recorded period. 

 Ok: clicking on Ok button closes the screen. 
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 Cancel: Clicking on cancel button closes the screen. 
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5 Phasor 

5.1 Phasor Menu 

The Phasor menu consists of the following options as shown in figure below: 

 

Figure 66: Phasor Menu 

5.2 Voltage Vectors - Hide 

On the Phasor menu, click Voltage Vectors – Hide as shown below: 

 

Figure 67: Voltage Vectors - Hide 

This will hide the voltage vectors as shown below: 
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Figure 68: Voltage Vectors Hide  

5.3 Voltage Vector – Show 

On the Phasor menu, click Voltage Vectors – Show as shown below: 

 

Figure 69: Voltage Vector - Show 

This will show the voltage vectors as shown below: 
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Figure 70: Voltage Vector – Show 

5.4 Current Vectors – Hide 

On the Phasor menu, click Current Vectors – Hide as shown below: 

 

Figure 71: Current Vectors Hide 
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Figure 72: Current Vectors Hide 

5.5 Current Vectors – Show 

On the Phasor menu, click Current Vectors – show as shown below: 

 

Figure 73: Current Vectors - Show 

This will show the current vectors as shown below: 
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Figure 74: Current Vectors – Show 

If both Voltage and Current are hidden than voltage & current diagrams will be 
displayed as shown below: 
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Figure 75: Voltage and Current Vectors – Show  

5.6 Scale Type – Current (s) 

On the Phasor menu, click Scale Type – Current (s) as shown below: 

 

Figure 76: Scale Type Currents 
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Scale/Rescale of vectors happens according to the selected options. If selected 
option is current then current vectors will be scaled /rescaled. 

5.7 Scale Type – Voltage (s) 

On the Phasor menu, click Scale Type – Voltage (s) as shown below: 

 

Figure 77: Scale Type – Voltage (S) 

5.8 Scale Plus 

On the Phasor menu, click Scale – Plus as shown below: 

 

Figure 78: Scale Plus 

On selection of this it changes the phasor magnitude. Scale plus is used for a better 
view of the phasor when the magnitude is less. Scale plus also happens according 
to the scale type’s selection. 

5.9 Scale Minus 

On the Phasor menu, click Scale – Minus as shown below: 

 

Figure 79: Scale Minus 

On selection of this option the phasor magnitude is reduced. Scale minus also 
happens according to the scale type’s selection. 

5.10 Scale to Normal 

On the Phasor menu, click Scale – To Normal as shown below: 

 

Figure 80: Scale to Normal 

On selection of this option the phasor magnitude is set to normal. 
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Note: Scale Pluse and Scale minus will not work if all the vector having equal or 
aproximattly equal magnitude 

5.11 Zoom Plot Area in Percentage 

On the Phasor menu, click Zoom Plot area in Percentage as shown below: 

 

Figure 81: Zoom Plot Area in Percentage 

         

Note: Plot Area in Percentage option gets enabled when user clicks on the phasor 
section in the comtrade viewer screen. 

5.11.1 Config Visibility 

On the Phasor menu, click Config Visibility as shown below: 

 

 

Figure 82: Config Visibility 

The following window appears: 
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Figure 83: Phasor Visibility 

The fields for voltage and current channels are described below: 

ID: This is the ID for the voltage/current channel. 

Channel Name: Channel name will be displayed as per the opened .cfg file. 

Status: This is the status of the channel. If selected by user, channel vector  
displays on the phasor diagram. If de-selected then it won’t be displayed in the 
diagram on comtrade viewer phasor section. 

Tabular Status: This is the status of the tabular data in phasor section . If selected 
by user, tabular data displays on the phasor diagram. If de-selected then it won’t be 
displayed in the diagram on comtrade viewer phasor section. 
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Figure 84: Phasor Visibility – De-selected 

In this window the voltage and current channels are there along with the status. If 
the user clears the check boxes for particular channels then the same will not  be 
reflected in the phasor window. The example of the same is explaned below. 

Phasor visibility before clearing the check box: 
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Figure 85: Voltage and Current  Phasor Visibility before De-selection 

Phasor visibility after clearing the check box: 
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Figure 86: Voltage & Current  Phasor Visibility after clearing the check box 

Note: channels other than Voltage and current  will not be displayed here. 
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6 Tools 

6.1 File Merge 

On the tools menu select file merge. 

 

Figure 87: File Merge 

The below screen appears: 

 

Figure 88: File Merge Window 

Comment [p2]: File merging need to 

update as per the new changes 
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File merge helps the user to merge two file types. In this screen user can do single 
or double file merge operation.  

No of Files: Select the number of files either single or double. 

File 1: Click  brows button, the following window appears: 

 

Select the file and click open. 

View: Click  button, to read the .cfg file as shown in figure below: 

 

Figure 89: File 1 - View 

New: Clicking on this button displays a blank page. Here user can create a new file. 

Open: Click this button to open an existing file. 
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Save: Click this button to save a new file. 

Print: Click this button to print the file. 

Cut: Click this button to cut the selected text. 

Copy: Click this button to copy the selected text. 

Paste: Click this button to paste the selected text. 

Undo: Click this button to undo the selected text. 

Select: Click this button to select the entire file. 

Clear: Clicking this button clears all the data. 

Find: Click this button which brings a pop up window as shown below: 

 

Figure 90: Replace 

User can replace any word and do the modifications. 

Start/End: A number of data is available in the file. To view the last set of data 
select end which takes you to the end of the file. Selecting start will come back to 
the first set of data. 

Next: Click this button to go to the next text. 

File 2:. Click  browse button for selecting 2nd file. If number of files is selected as 
single, this option will be disabled. 

 

Select the file and click open. 
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View: Click  this button, the following window appears: 

 

Figure 91: File 2 - View 

New: Clicking on this button displays a blank page. Here user can create a new file. 

Open: Click this button to open an existing file. 

Save: Click this button to save a new file. 

Print: Click this button to print the file. 

Cut: Click this button to cut the selected text. 

Copy: Click this button to copy the selected text. 

Paste: Click this button to paste the selected text. 

Undo: Click this button to undo the file. 

Select: Click this button to select the entire file. 

Clear: Clicking this button clears all the data. 

Find: Click this button which brings a pop up window as shown below: 
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Figure 92: Replace 

User can replace any word and do the modifications. 

Start/End: A number of data is available in the file. To view the last set of data 
select end which takes you to the end of the file. Selecting start will come back to 
the first set of data. 

Next: Click this button to go to the next text. 

Output File: Click on   brows button which brings the following dialog box: 

 

Figure 93: Save As File 

Here the you can specify the path where you want to save the file. 

File no 1 info: After selecting 1st file, aapplication displays the following 
information. 

Sample Number (From to To Number): Sample number should get reflected in 
this field according to .cfg files. 

Frequency: The frequency is as per the selected .cfg file. 

Start Date: Start day will be displayed as per the selected .cfg file. 

Start Time: Start time will be displayed as per the selected .cfg file. 

Trigger Date: Trigger date will be displayed as per the selected .cfg file.  

Trigger Time: Trigger timewill be displayed as per the selected .cfg file. 
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File no 2 Info: After selecting 2nd file, aapplication displays the following 
information. 

Application displays the following information. 

Total Sample: Sample number should get reflected in this field according to 
selected .cfg file. 

Frequency:  The frequency is as per the selected .cfg file. 

Start Date: Start day will be displayed as per the selected .cfg file. 

Start Time: Start time will be displayed as per the selected .cfg file. 

Trigger Date: Trigger date will be displayed as per the selected .cfg file.  

Trigger Time: Trigger time will be displayed as per the selected .cfg file 

 

From number : From number displays 1 by default. 

To number: To number is displayed according to the total sample present in the 
.cfg file 

Note: User can change from sample number and To sample number according to 
their choice. 

When two files are selected for merging, the sample number which has got the  
minimum value should be displayed on the screen. 

Start time: This is the start time. User can change this time according to the  
convenience. 

Trigger time: User can also set the trigger time. 

Frequency: User can set the frequencey . 

Select: Merging of files depends on the selection of analog and digital channels. If 
you want to select particular channles to be merged then select the check boxes in 
the file. 

File 1 Analog channel: This is analog channels for file-1. 

Select: Merging of files depends on the selection of analog and digital channels. If 
you want to select particular channles to be merged then select the check boxes in 
the file. 

File 2 Analog Channel: This is analog channels for file-2. 

Select: Merging of files depends on the selection of analog and digital channels. If 
you want to select particular channles to be merged then select the check boxes in 
the file. 

File 1 Digital Channel: This is digital channels for file-1. 

Select: Merging of files depends on the selection of analog and digital channels. If 
you want to select particular channles to be merged then select the check boxes in 
the file. 

File 2 Digital Channel: This is analog channels for file-2. 
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The sample file merging window is shown in figure below: 

  

Figure 94: Single/Two File Merging 

Clicking on the ok button new file should be generated in specified output path and 
same should be displayed in comtrade viewer 

           Click Cancel to cancel the above actions. 
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7 Window 

7.1 Cascade 

The window menu consists of the following options as shown in figure below: 

 

Figure 95: Cascade 

On selection of cascade option, the window is set to cascade style. 

On selection of tile option, the window is set to tile style. 
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8 MiCtViewer Data Display Screen 

The data display screen has three sections, analog, digital and phasor as shown 
below: 

 

Figure 96: MiCtViewer Data Display Screen 

8.1 Analog and Digital Viewer Options  

 

Figure 97: Analog View 

Analog view section has fourteen buttons, these are: 

 Scale plus for X/Y axis: On click of this button channel will get scale for a 
better view. Scale plus happens according to the scale types(X or Y-axis) 
selection. 

 Scale minus for X/Y axis: On click of this button, channel will get rescale 
negative direction. Scale minus happens according to the scale type’s X or 
Y-axis) selection. 

 Restore: Click this button to restore the previous action.  

 Display Tabular Data: Click this button to display tabular data. 

 Clip Boundary: Clip boundary helps to control the overlapping of the 
channels. 

 Axis Selector: This is the axis selector for the X and Y axis. 

 Zoom plot area in percentage: This is the percentage area for zoom. 

 Fit to View Width: Click this button to view the window in width direction. 
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 Fit to Minimum Height: Click this button to view the window in minimum 
height direction. 

 View Comparison: Click this button to view the comparison of channels. 

 View  Computational : this button to view Computational of channels 

[Note: View comparison and View Computational buttons will get enable 
only if channels are selected on comtrade viewer screen]  

 View Harmonics: Click this button to view the harmonics. 

 Show Label: Click this button to view the label. 

 Mouse Action - Scroll View: Clicking this button enables the screen to 
scroll view. 

 Mouse Action - Scroll Reference: Clicking this button the reference axis is 
set to move. 

Tabular Data: Tabular data shows the computed values of the channels. Tabular 
data is having ten columns and those are: 

 Title: Title is the user defined naming convention for the channel as per the 
.cfg file. 

 Units:  Unit of the particular channel. 

 InstValue: This is the instantaneous value of the waveform. 

 DFT Peak: DFT Peak is the peak magnitude calculated for one cycle from 
the reference. 

 RMS: This is the RMS value for fundamental. 

 Phase: This is the vector phase angle.  

 InstMaxPeak:  The positive peak value in the selected cycle. 

 InstMinPeak: The negative peak value in the selected cycle 

 InstValue: Value of the sample where the reference is pointing to. 

 MAXPeak:  MaxPeak is the maximum positive Instantaneous value of the 
corresponding channel for the entire recorded period. 

 MINPeak: MinPeak is the Minimum negative Instantaneous value of the 
corresponding channel for the entire recorded period. 

8.2 Scale plus for X/Y Axis 

Scale plus for X/Y Axis works according to the selected axis type. Select a channel 
and click the scale plus for X/Y axis button.  This will zoom the channel as shown 
below: 
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Figure 98: Channel Scale Plus 

8.3 Scale minus for X/Y Axis 

Scale minus for X/Y Axis works according to the selected axis type. Select a 
channel and click the scale minus for X/Y axis button. This will zoom out the 
channel as shown below: 

 

 

Figure 99: Channel Scale Minus 

8.4 Restore Button 

Click this button to go back to the earlier settings. 

8.5 Tabular Data 

You can select or deselect the tabular data. Click the tabular data tab which brings 
the following page as shown below: 
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Figure 100: Tabular Data 

This displays the column name and all the information related to the channels. 
Once the user deselects the tab, the detailed information goes off as shown below: 



MiP-PSCT                                                                                                                                       COMTRADE Viewer User Manual 

 

Power Research and Development Consultants Pvt. Ltd. Page 76 
 

 

Figure 101: Tabular Data without any Information 

8.6 Clip Boundary 

Clip boundary tab helps to control the overlapping of channels. When user selects 
the clip option the overlapping portion of the channel will get clipped: 
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Figure 102: Clip Boundary on 

When user de-selects the clip portion the clipped portion will get unclip as shown 
below 
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Figure 103: Clip Boundary off 

8.7 Axis Selector 

 

Figure 104: Axis Selector 

Axis - Y: When you choose this option, then the selected channels are scaled in Y 
axis direction as shown below: 

 

 

Figure 105: Y Axis Zoom 

Axis - X right: When you choose this option, all the selected channels are scaled 
towards right side as shown below: 
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Figure 106: Zoomed in X Axis 

Axis - X left: When you choose this option all the selected channels are scaled 
towards left direction as shown below: 

 

 

Figure 107: Zoomed in X Axis Left 

Axis - X left and right: When you choose this option, all the selected channels are 
scaled towards both left and right as shown below: 
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Figure 108: Zoomed in X and Y Axis Right 

8.8 Plot Area Zoom 

The plot area can be zoomed from 100 to 300 hundred percent as shown below: 

 

Figure 109: Plot Area Zoom 

Once the percentage is selected, for the whole window the plotted area will be 
zoomed as shown below: 
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Figure 110: Plot Area Zoomed 

8.9 Fit to View Width  

When this button is clicked the plot area width will be fit to the view window width as 
shown below: 

 

Figure 111: Fit to View Width 

 

Once you deselect it comes back to its normal position. 

8.10 Fit to Minimum Height 

When this button is clicked the plot area height will be fit to minimum height of the 
window as shown below: 
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Figure 112: Fit to Minimum Height 

Once you deselect, it comes back to its normal position. 

8.11 View Comparison 

View comparion button helps to do comparison between any number of channels. 
User can open and select the required number of channles on comtrade viewer and 
then clicking on the view comparison button comparison window will get display 
with selected channels as shown below: 
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Figure 113: Comparison Screen 

Click close to go back to the Comtrade viewer screen. 

8.12 View Computaional  

View Computaional button helps computaional view of channels. User can open 
and select the required number of channles on comtrade viewer and then clicking 
on the view Computaional button Computaional Viewe window will get display with 
selected channels as shown below: 

 

Select one or more select check box’s and click on Ok button which brings the following 
page :  
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In this page the Compuataional view  has  been displayed. 

8.13 View Harmonics 

Harmonic values are displaying according to the selected sample or cycle  

as shown below: 

 

Figure 114: View Harmonics 

Sample: When sample is seleccted then harmonics values in the table are 
displayed according to sample. Sample moves by one number at a time. For 
example if the sample is at 1 and you click move next it will go to 2. 

Comment [p3]: Need to update as per 
the new changes 
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Cycle: When cycle is seleccted then harmonics values in the table are displayed 
according to cycle. When the user selects cycle, one cycle moves at a time. For 
example if the cycle number is 1 and you click move next the next cycle will jump to 
21 if number of samples per cycle is 20.  

From Sample to To Sample: From sample and to sample 

 

 reflects the sample number/cycle number in the field. Enter specific sample number 
or cycle number and click on tab it will go to particular sample/cycle. 

Total Samples: should display as per the opened .cfg file. 

Samples/cycale: should display as per the opened .cfg file. 

Move First: Clicking this  button takes you to the first sample/cycle. 

Move Previous: Clicking on this  button takes you to the previous 
sample/cycle. 

Move Next: Clicking on this  button takes you to the next sample/cycle.  

Move Last: Clicking on this  button takes you to the last sample/cycle. 

Trigger Point: Clicking this  button will trigger point. 

Close: clicking on close button window should get close.  

8.14 View Analog tabular Data:   

Tabular Data values are displaying according to the selected sample or cycle  

as shown below: 
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8.15 Labels 

This is a toggle button. Clicking this button will display the maximum and minimum 
value for all the channels as shown below: 

  

Figure 115: Labels - Selected 

Once you deselect label data should not display as show below: 

 

Figure 116: Labels – De-selected 
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8.16 Mouse Action - Scroll view 

Clicking on this button scrolls the window vertically. 

8.17 Mouse Action  - Scroll reference 

Clicking on this button moves the Y axis. 

Note: Both the buttons cannot work simultaneously. 

8.18 Mose Action –Tool tip X-Y Values 

Clicking on this button displayes the tool tip edit box on comtrade viewer accoring to 
the selected sample . 

8.19 Pan Graph 

Clicking on this button enables the paning option for the comtrade viewer graphs 
section  

8.20 Analog Plot – Right-click Options 

In the analog plot there are several right-click options available for the user. Those 
are: 

 Channel Color 

 Show all 

 Show Voltage Channels 

 Show Current Channels 

 Show Other Channels 

Comment [p4]: Need to mention set as 

reference Axis option  
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Figure 117: Analog Plot – Right-click Options 

Channel Colour: This option will be enabled when you right-click on analog 
channel number. Now right-click and select Channel colour. The color palette will be 
available as shown below: 

 



MiP-PSCT                                                                                                                                       COMTRADE Viewer User Manual 

 

Power Research and Development Consultants Pvt. Ltd. Page 89 
 

 

Figure 118: Colour Palette 

Now select the particular color and click Ok. The color for that number will be 
changed as shown below: 

 

Figure 119: Changed Channel Colour 

Show all: Upon right-click on the channel number, you get the option show all. 
Under show all there are three sub-menus as shown below: 

 

Figure 120: Show All 

Default: Select Show All > Default. All the analog channels will be displayed with 
default options. 

Sort Channel Title A to Z: Select Show All > Sort Channel Title A to Z. All the 
analog channels will be sorted according to title ascending order. 
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Sort Channel Title Z to A: Select Show All > Sort Channel Title Z to A. All the 
channels will be sorted according to title descending order. 

Show Voltage Channel: On selection of this option, only voltage channels will be 
displayed. 

 

Figure 121: Show Voltage Channel 

Show Current Channel: On selection of this option, only current channels will be 
displayed. 



MiP-PSCT                                                                                                                                       COMTRADE Viewer User Manual 

 

Power Research and Development Consultants Pvt. Ltd. Page 91 
 

 

Figure 122: Show Current Channels 

Show Other Channels: This option will be enabled if the .cfg file contains other 
than voltage and current channels like frequency, neutral etc. 
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Figure 123: Show Other Channels 

Note: If there is no analog channel in the .cfg file then analog and phasor option in 
the view menu will be in disabled state. 

8.21 Phasor View Options 

The phasor window displays the voltage, current and both voltage and current 
diagram. The phasor diagram shows the vector for each voltage and current 
channel. When the user navigates through the samples its corresponding values 
reflect in phasor diagram. User can increase  or decrease the size of the phasor 
window. The length of a channel's vector mark can be scaled or rescaled. User can 
change the display of the voltage and current diagram by checking/unchecking the 
voltage and current tabs available in the window. 

8.21.1  Voltage 

This shows the vector for all voltage channels. 
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Figure 124: Voltage Channel 

8.21.2 Current 

This shows the vector for all current channels. 

 

Figure 125: Current Channel 

8.21.3 Voltage and Current 

This shows the vector for both volate and currnet channels. 

 

 

Figure 126: Voltage and Current Channel 
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8.22 Digital View 

The digital display shows all the digital channels along with the status at each 
sample. The present status values of the channels is updated as the user navigates 
through the samples. A user can mark /unmark, hide/show the channels.  The 
digital view screen is as shown below: 

 

Figure 127: Digital View 

The digital view is consists of seven columns. Those are: 

 Current-Status: User can see the current status as 1/0. If the status is 1 
means The current status is on. If the status is 0 means the current status is 
off.  

 Name: The name  is read from the .cfg file. 

 Start Status: Start status reflects the current status of that channel at the 
beginning.   

 End Status: End status means the current status of that channel at end. If 
the channel is ended with current status is on will reflect 1, if it is not then it 
will show as 0. 

 First Change: The time when the first change happened in the channel.  

 Last Change: The time the Last change happened in the channel. 

 Change Count: It is number of variations in channel. 

Note: If there is no digital channel in the .cfg file then the digital channel option in 
the view menu will be in disabled state. 

8.23 Digital Plot – Right-click Options 

In the digital plot there are several right-click options available for the user. Those 
are: 

 Channel Colour 
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 Show all 

 Show Operated 

 Show not Operated 

 

Figure 128: Digital Plot – Right-click Options 

Channel Colour: This option will be enabled when you right-click on digital channel 
number. Now right-click and select Channel Colour. The colour palette will be 
displayed as shown below: 
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Figure 129: Colour Palette 

Now select the particular colour and click Ok. The colour for that number will be 
changed as shown below: 

 

Figure 130: Changed Channel Colour 

Show All: Upon right-click on the channel number, you get the option show all. 
Under show all there are five sub-menus as shown below: 

 

Figure 131: Show All 

Default: Select Show All > Default. All the digital channels will be displayed with 
default options. 

Operating Time ASC: Select Show All > Operating Time ASC. All the channels 
will be sorted according to operating time in ascending order. 

Operating time DSC: Select Show All > Sort Channel Title Z to A. All the 
channels will be sorted according to operating time in descending order. 
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Sort Channel Title A to Z: Select Show All > Sort Channel Title A to Z. All the 
channels will be sorted according to title in ascending order. 

Sort Channel Title Z to A: Select Show All > Sort Channel Title Z to A. All the 
channels will be sorted according to title in descending order. 

Show Operated: Upon right-click on the channel number, you get the option Show 
Operated. Under Show Operated there are three sub-menus as shown below: 

 

Figure 132: Show Operated 

Default: Select Show Operated > Default. All the operated channels will be 
displayed with default options. 

Operating Time - ASC: Select Show Operated > Operating Time ASC. All the 
operated channels will be sorted according to the time in ascending order. 

Operating Time - DSC: Select Show Operated > Sort Channel Title Z to A. All 
the channels will be sorted according to the time in descending order. 

Show Not Operated: Select Show Not Operated. It will show the non-operated 
channels. 
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