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1. Introduction 
MiPContour is a graphical tool which is used to draw a distance relay characteristics library. This tool is used to 
create a characteristics library as per the relay settings, and it is also used to solve various problems such as: 
1. Variety of relay characteristics 
2. Vendor specific data format 
3. Entering the details of relay characteristics which is time consuming process 
4. Modifying relay characteristic to match particular scenario, which is not available 
5. Allowing to develop user defined characteristics 
6. Accurate visualization of the relay characteristics on one platform 

 

2. Features 
Following are the features of MiPContour: 

 
1. Concept of layer for defining zones of operation 
2. Facility to enter co-ordinates 
3. Option to create separate library for phase and earth 
4. Option to enter the characteristics on primary or secondary side of CT/CVT 
5. Option to set the range 

 
3. Launching MiPContour 

Follow these steps to launch MiPContour: 
 

1. In MiP- PSCT screen, click the 21 button. This displays the following screen: 

In this window, by clicking the Create button you can create a new relay characteristics library or even you 
can open already created library. 

2. Select User Defined from Characteristics field. 

3. By clicking the Create button, MiPContour: Relay Characteristics Development Tool window appears. 
 
 
 
 
 
 

4. Menu Bar 
 
 
 

Following are the menu available in this application: 

1. File 

2. View 

3. Format 

4. Distance Relay Characteristics 

5. Help 
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File 
 
Following are the various options which are available under the File menu: 

 
5.1 Save As Image 

 
This options allows you to save the drawn relay characteristics as an image. 
 
1. By clicking Save As Image option under File menu, Save Graph as an Image dialog box appears. 

 

 
 
 

Browse and select the location for the file to be stored. 
 

2. In the File name field, type the file name, and then click Save to save the file as an image. 
3. The shortcut for this option is Ctrl+I. 

 
 
5.2 Save As Characteristics Library 

 
This options allows you to save distance relay as a characteristics library. 

 
1. By clicking Save As Characteristics Library option under File menu, Add Characteristics Library dialog box 

appears. 
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Note: This option is enabled only when a Relay Characteristics is created. 

 
2. In this dialog box, automatically the Library No. will be generated. 
3. Phase has been selected in the tool bar, so by default Phase radio button will be marked as checked. 
4. Primary/Secondary radio button will be selected automatically depending upon the relay manufacturer 

specification. For generic relays user have to select Primary/Secondary explicitly. 
5. Click Save button, to save the distance relay as a characteristics library for phase. 
6. Once the distance relay saved for Phase, again the Add Characteristics Library dialog box appears 

to save the distance relay for Earth. 
7. Click Save button, to save the distance relay as a characteristics library for Earth. 
8. You have successfully saved the distance relay characteristics. The shortcut for this option is Ctrl+S. 

 
 
5.3 Print 

 
This options allows you to print the relay characteristics library. 

 
1. By clicking Print... option under File menu, Print dialog box appears. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. In this dialog box, you can select the Printer name, Print range, and number of copies you want to print. 
3. Once you setup the printer, click OK button. This will print the select page. 
4. The shortcut for this option is Ctrl+P. 
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5.4 Print Preview 

 
This options allows you to preview the page which you want to print. 

 
1. By clicking Print Preview option under File menu, you can view the preview of the page. 

 

 
In this page, the following are the options available: 

 
 

Buttons Description 

Print... This option allows you to print the selected page 

Next Page This option takes you to the next page 

Prev Page This option takes you to the previous page 

Two Page This option displays the two pages preview at a time 

One Page 
If you selected Two Page option, then this option will be enabled. This 
option displays only one page preview 

Zoom In This option allows you to zoom in the page 

Zoom Out This option allows you to zoom out the page 

Close This option will close the Print Preview page 

 
5.5 Print Setup 

 
This options allows you to setup the printer properties. 

 
1. By clicking Print Setup... option under File menu, Print Setup dialog box appears. 
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2. In this dialog box, you can select the printer, paper size, paper source, and orientation. 
3. Once you setup the printer, click OK button. This will save the setup. 

 
5.6 Page Setup 

 
This options allows you to setup the page properties. 

 
1. By clicking Page Setup option under File menu, Page Setup dialog box appears. 
2. In this dialog box, you can setup the dimension, margin, plot size, and border area of the paper. 
3. By clicking the Default Values button, the default values will be setup for the page. 

 
 

5.7 Exit 
 
Click File> Exit ,to close the MiPContour application. A 
confirmation dialog box is displayed. 
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On Click of  ‘Yes’ button application is closed. 

View 
 
Following are the options available in the View menu: 

 
6.1 Toolbar 

 
Use View > Toolbar to show or hide the tool bar. This option will be either be ON/OFF. If the option is ON, the 
tool bar is displayed, else the tool bar is hidden. 

Following are the options available in Toolbar: 
 

Options Description 
 

 

Save As Characteristics Library : This option allows you to save distance relay as a 
characteristics library. 

 

 

Print : This option allows user to print the distance relay characteristics which is 
displayed on the current screen . 

 

 

Layers Control : This option allows you to show/hide the zones. 

 

 

Range : This option allows you to set the range of the axis. 

 

 

Selection : By enabling this option you can select a particular zone in the 
drawing. 

 

 

CLEAR : This option will clear the screen. 

 

 

EDIT : This option allows you to edit the drawn distance relay characteristics library. 
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PHASE : By selecting this option you can see the phase drawing of a distance 
relay characteristics. 

 

 
EARTH : By selecting this option you can see the earth drawing of a distance relay 
characteristics. 

 

 
DELETE : This option will delete the current characteristics. 

 

 
First : This option will take you to the first library. 

 

 
Previous : This option will take you to the previous  library . 

 

 
Next : This option will take you to the next library. 

 

 
Last : This option will take you to the last library. 

 

 
Rectangle : This option is used to draw rectangle shape. 

 

 
Square :This option is used to draw square shape. 

 

 
Circle :This option is used to draw circle shape. 

 

 
Line at an angle :This option is used to draw line at an angle. 

 

 
Polygon : This option is used to draw polygon. 

 

 
Polyarc :This option is used to draw polyarc. 

 
 

6.2 Status Bar 
 
Use View > Status Bar to show or hide the status bar. This option will be either be ON/OFF. If the option is 
ON, the status bar is shown, else the status bar is hidden. 
The ranges of X and Y axis are shown in the Status Bar. 

 
 

6.3 Layers Control 
 

This option allows you to show/hide the zones. 

1. By clicking Layers Control option under View menu, Layer Control dialog box appears. 
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2. In this dialog box, you can see all the default zones. 

3. You can select the zones by clicking the check box under Show/Hide list, and then click OK. 

4. By clicking Check All button, all the zones are marked as checked. 

5. By clicking UnCheck All button, all the zones are marked as unchecked. 

6. By clicking Cancel button, Layer Control dialog box will be closed. 
Example: 
1. In Layer Control dialog box, select all the zones. 
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2. The distance relay characteristics drawing will be: 

3. Now, in the Layer Control dialog box, click the UnCheck All button and select the zones of your choice. 
4. Click the OK button. 
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5. Now, only the selected zones will be displayed in the distance relay characteristics drawing. 

 
 

6.4 Data Sheet 
 

This option opens a data sheet window in a new window. 
 
Format 

 

 
Following are the various options which are available under the Format menu: 
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7.1 Back Ground Color 
 
This option allows you to set the back ground color of the plotting area. 
1. Click on BackGroundColor option in Format menu. 

 
 

Color dialog box appears. 
2. Select the color of your choice. 
3. Click OK button. 

 

 
This will apply the selected color to the back ground of the page. 
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7.2 Axis 
 
This option allows you to set the axis and grid properties for R-Axis and X-Axis. 

 

1. Click on Axis option in Format menu. 

Axis & Grid Properties dialog box appears. 
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2. In this dialog box, you can set the axis and grid properties along R-Axis and X-Axis such as: 

 
 Aligning, setting the color, and thickness along the Axis 
 Setting the number of ticks, and color 
 Aligning, setting the precision, and font for the Label 
 Setting the number of grid lines, and color for the Grids 

 
7.3 Range 

This option allows you to set the range. 

By default the Resistance R-Axis range will be set to Min (-100), and Max (100). Similarly, the 
Reactance X-Axis range will 

be set to Min (-60), and Max (60). 
You can also define the range as per the requirement. 

 
1. Clicking on Range option in Format menu. 

 

Range of the Axis dialog box appears. 

 
 
 

2. Under R-Axis, and X-Axis, you can define the range as per your requirement, and then click OK. This 
will plot the graph according to the defined R and X Axis. 

 
By clicking Default button, the default range i.e, -100 to 100 for R-Axis, and -60 to 60 for X-Axis will be set. 
 

Help 
 
The help menu consists of following: 
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8.1 Help Topics 
 
This option opens a help file of the application. 

 
8.2 About MiPContour 

 
This option contains the details of the application. 

 
 

Distance Relay Characteristics 
 
This feature allows you to either: 
Creating a new Manufacturer Specific Distance Relay Characteristics. 
Viewing & Editing Existing Distance Relay Characteristics 
Creating User Defined Distance Relay Characteristics. 
Viewing & Editing User Defined Distance Relay Characteristics. 
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9.1 Create: Manufacturer Specific Distance Relay Characteristics 

 
Follow these steps to create a new distance relay characteristics: 

 

1. Click the Distance Relay Characteristics on the menu bar. 

Distance Relay Characteristics dialog box is displayed. 

2. Click on  radio button to select Create New . 

3. Select the manufacturer from the MAKE list box. 

4. Select the version from the MODEL list box. 
After selecting manufacturer and  version, Library No is generated automatically. 

5. Click the Create button. 
 
 

 

This displays a MICOM P442 dialog box. 



MiP-PSCT MiPCONTOUR User Manual   
 

Power Research and Development Consultants Pvt. Ltd  Page 18 
 

 
 

 
In this dialog box, you can set up the zones by entering the values for each zones or you can leave with the 
default values. 
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 Note: 
Zones and the default values will be different for various MAKE and 

MODEL. 

7. Once you setup the zones, Click OK button. 

 

This will draw a new distance relay characteristics for both PHASE and EARTH. 
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PHASE: 

 
 

 
 

EARTH: 
 
 

 
 

You have successfully drawn a new distance relay characteristics. Now, you need to save the newly drawn distance 
relay characteristics. 
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Saving distance relay characteristics: 
 

1. Click File> Save As Characteristics Library or Save button from the tool bar. To select 
the zones refer Layers Control. 
Following are the available MAKE, and MODEL: 

 
 

 

 Note: 
Similarly, you can create a new distance relay characteristics for various MAKE and 
MODEL. 

 
 

9.2 View & Modify: Existing Distance Relay Characteristics 
 
Follow these steps to view and edit the already created distance relay characteristics: 
1. Click the Distance Relay Characteristics on the menu bar. 

MAKE MODEL 
 
 
 

1.  [ABB] 

1 [REL100] 
2 [REL521] 

3 [REL531] 
4 [REL670] 

17 [REL316] 

 

2. [SIEMENS] 
5 [7SA511] 
6 [7SA513] 
7 [7SA522] 

 
 
 

3.  [AREVA] 

8 [MICOMP444] 

9 [MICOMP442] 

10 [MICOMP441] 

65 [MICOMP437] 

66 [MICOMP546] 

 

4. [ALSTOM] 
11 [EPAC3000] 
12 [EPAC3100] 
13 [EPAC3500] 

 
5. [OHMEGA] 14 [OHMEGA406] 

15 [OHMEGA407] 

6. [GE] 16 [D60] 

7.  [TOSHIBHA] 116 [GRZ100] 

8 . [SEL] 
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Distance Relay Characteristics dialog box is displayed. 
2. Click on View & Edit radio button. 

M&M and User-Defined radio buttons are enabled automatically after selecting View & Edit. Note: M&M 
is selected by default. 

3. Select the manufacturer from the MAKE list box. 
4. Select the version from the MODEL list box. 

5. Select standard Relay characteristics Library number from Element/Characteristics Info combo box. 

6. Click on View button. 

 

This displays the distance relay characteristics for both PHASE and EARTH. 
PHASE: 
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EARTH: 
 
 

 
 

You have successfully viewed the already drawn distance relay characteristics. 
7. On clicking the User-Defined radio button, MAKE and MODEL list gets disabled. 
8. Select standard Relay characteristics Library number from Element/Characteristics Info combo box, click 

the View button. 
 

To edit the distance relay characteristics refer Layers Control, and to save the drawing refer Save As 
Image and Save As Characteristics Library. 

 

9.3 Create: User defined Distance Relay Characteristics 
 
1. Click to select on the required shape button. 
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2. Draw the shape in MiPContour page. 

 

Shape details window is displayed. 
3. Modify the existing details as per requirement. 
4. Click OK button. 

 

 
 

5. Click on Selection button. 

Right click on the shape to open a context menu. 
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6. Go to "Change Layer" and Select the required zone. 

7. Click on Save As characteristics Library button. 

 

User defined Distance Relay Characteristics is created. 

 

9.4 View & Modify: User Defined Distance Relay Characteristics 
 
1. Click the Distance Relay Characteristics on the menu bar. 

 

 
 
Distance Relay Characteristics dialog box is displayed. 
2. Click to select View & Edit radio button. 
3. Click to select User-Defined radio button. 
4. Select the required library from the Element/Characteristics Info combo box. 
5. Click View button. 

The selected distance relay characteristics is displayed. 
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Note: Select Selection button,if not selected. Right click 
on the shape to open a context menu. 

6. Click on Edit Settings. 

7. Edit the required fields. 
8. Click OK button. 

 

 
 
This edits the User defined Distance Relay Characteristics. 
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